気まま日記(kimamanikki)

気の向くままに、のんびり更新しますヽ(´∀`)ノ

 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
08


スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

古い JDK5 とか J2SDK1.4 とか欲しいとき

現在のJavaの開発環境であるJDKのバージョンは6ですが、皆さん最新のJDK6を使ってますか?

僕はJDK5を使ってます。

だって・・・JDK6のバージョン1.6.0_14 ~ 15だと、Eclipseでデバッグする際にブレークポイントが無視されるというバグが潜んでいるからです。
厳密にはEclipseがとかではなく、JavaVMのGCに問題があったみたいで、最新のバージョンでは修正されています。
アップデートリリースノート:1.6.0_15 / 1.6.0_16
Bug ID:6862295
※リリースノート1.6.0_15によると、デバッグの実行パラメータに -XX:+UseParallelGC を設定してやれば動くみたいですね。

以前そういった経験をしまして、それ以来JDK6よりもJDKの5を使うようにしています。

でも今のSunのサイトに行っても最新のJDK6がダウンロード出来るだけで、過去のものはダウンロードできません。
(一部のJDK5はダウンロード出来るようです→コチラ

でも、「現場の環境がまだ J2SDK1.4 だ~!」とか、「JDK5のあのバージョンが欲しいのに!」とか、そういった方もいらっしゃるかと思います。

そういった方は・・・

前のJavaのバージョンであるJDK5とか、J2SDK1.4が欲しい方はこちら※をクリック☆

ってかこのページもっと前面に出しておけば良いのにね。

皆がみんな最新バージョンを使うとは限らないし。

まぁさすがにJDK1.1とかJ2SDK1.2は使わないだろうけど(^▽^;)

※どうやら公式ページからarchiveへのリンクは現在消されているようです。
ページ自体は存在して機能しているので、何らかの理由でリンクのみが消されたのかも?
まぁ僕が見落としているだけかもしれませんがσ(^_^;)


Comments

No title
あけましておめでとうございます。
新年のご挨拶記事には間に合いませんでした~

Java記事を見ながら???な状態のフィールです。
PCはキー押す程度の能力しかないもので~w
むむむ…

ま、まずは基本から学習しないと^^;

今年もよろしくおねがいします。

Leave a Comment


Body

カウンター
セルフィ

 
Twitter



 
 
クラッチ作品集
 
 
プロフィール

クラッチ

気まま日記バナー

・クラッチ
このブログの管理人

 
 
管理人へメール
メールフォームを開く
 
 
ブロとも申請フォーム
 

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。